更新Android Studio 2.0之後Gradle版本錯誤

終於等到官方釋出了Android Studio 2.0穩定版,這次版本推出了好幾項開發過程相當好用的功能,所以是一定要升級的版本。

但從舊有的版本升級之後卻不能build code了,出現了下列的錯誤訊息:
Error:(1, 1) A problem occurred evaluating project ':app'. > Failed to apply plugin [id 'com.android.application'] > Gradle version 2.8 is required. Current version is 2.2.1. If using the gradle wrapper, try editing the distributionUrl in /Documents/AndroidDev/source_code/project_name/gradle/wrapper/gradle-wrapper.properties to gradle-2.8-all.zip


上網查的結果,發現也有人提到這幾乎都是每次版本更新時常會發生Gradle版本不適合的老問題了,於是照著錯誤訊息中指出的檔案修改:

在Android Studio的左邊選單找到gradle/wrapper/gradle-wrapper.properties

開啟之後,找到原本的版本名稱(以本例的版本是2.2.1)


修改成2.8,但已經有人發生版本要求為2.10了,所以可以直接就先改成2.10了,而改成2.10之後也是確定可以正常使用的


接著還有可能會發生Gradle Plugin版本不適合的問題


Gradle Plugin更新完之後會發現classpath裡的gradle版本已經變成2.0.0


Reference:
http://stackoverflow.com/questions/34605667/android-studio-gradle-version-gradle-version-2-8-is-required

留言

這個網誌中的熱門文章

Mac安裝JDK後仍出現沒有runtime的錯誤 No Java runtime present, requesting install

Android使用Callback做為傳遞資料/通知的方法

如何實作從API抓取資料顯示在列表頁(ListView)上